On Monday 27 January 2003 10:51 am, Markus Werle wrote:
Well, assumed I have good reasons to use boost::bind and ::_1 in one case and boost::lambda::_1 in another place in the same file.
You could rename Lambda's placeholders to something that doesn't conflict with Boost.Bind's placeholders: http://www.boost.org/libs/lambda/doc/ar01s05.html
and "using namespace boost" is not an option for all users (it brings in a lot of names that might conflict with user code).
I agree. So what about another nested one: boost::function::placeholders
boost::function is part of the Function library, which is distinct from both Bind and Lambda, so I assume you mean boost::bind::placeholders. There are technical issues with that exact formulation (boost::bind can't be both a namespace and a function template), but I do not know why a similar solution was not implemented.
I keep hoping that Boost.Bind's _1 and Boost.Lambda's _1 will become the same entity at some point...
In 2012?
[Moderator: Do remember that Boost is a volunteer effort. No developer is obligated to fulfill user requests, and the motivation to do so is lessened by inflamatory remarks of this nature.] Doug