"Peter Dimov"
David Abrahams wrote:
Could the authors of the libraries (or the reviewers) please grep through the code and change the cassert (or assert.h) includes to boost/assert.hpp, and consequently, change assert(...) to BOOST_ASSERT(...)?
It's a very good idea, and I think we should do it.
Although I guess we have to be pretty careful, since things like polymorphic_downcast are documented as using the standard assert macro. Technically speaking, it's a breaking change.
BOOST_ASSERT defaults to assert, though. So it might be acceptable, even though BOOST_ASSERT wasn't meant to be used in interfaces.
That's why I said "technically speaking." Actually it occurs to me that our testing shouldn't use BOOST_ASSERT at all, but instead the test library or boost/detail/lightweight_test.hpp, the latter probably being slightly closer to a drop-in replacement for cassert. -- Dave Abrahams Boost Consulting www.boost-consulting.com