
26 Feb
2014
26 Feb
'14
3:27 p.m.
Hi! I'm finally getting around to spending some decent time tackling tickets on Boost.Range and I'm finding the rather verbose BOOST_DEDUCED_TYPENAME to be considerably worsening the readability of my new code. I believe this existed to cope with very old compilers which we no longer officially support in new versions of Boost. Should I continue to put this in, or is it reasonably to drop a painful workaround for such an old compiler issue? Neil Groves