The title says it all really, but in more detail: 1) Is there any existing best practice we should follow yet? 2) Can we share code content effectively between headers and modules? And by modules I mean "proper" ones: we should be able to write "import boost.whatever;" rather than importing a header. 3) What directory structure should we all be using for module definition files? 4) Do we have Boost.Build support yet? 5) What file extensions should we be using? 6) I presume we would all use the boost.libraryname and boost.libraryname.sub_feature naming convention with boost.libraryname pulling in the whole library? 7) Does anyone have a handle on the current state of std library modularization? 8) Is there demand for this? And no doubt lots of other things I haven't thought of. Curiously yours, John.