On 27.02.21 23:53, Richard Hodges via Boost wrote:
Please provide in your review information you think is valuable to understand your choice to ACCEPT or REJECT including Describe as a Boost library. Please be explicit about your decision (ACCEPT or REJECT).
I vote to ACCEPT Boost.Describe. Although the library has some weaknesses (which have already come up in the review process), I do not consider them serious enough to delay the acceptance of Boost.Describe. Boost.Describe in its present form already passes the "would I use it" test.
Some other questions you might want to consider answering:
- What is your evaluation of the design?
It's a good minimalistic building blocks for higher level abstractions. The lack of a way to add annotations to described members is problematic. Normally, types in C++ can be externally annotated by defining a traits class template, but this is not really an option for the Di types returned by Boost.Describe, since they have no public names.
- What is your evaluation of the implementation?
The library adds functions to user-defined namespaces, which introduces the possibility of name collisions. For example, BOOST_DESCRIBE_ENUM adds a function called _enum_descriptor_fn. A better name for this function would be _boost_describe_enum_descriptor_fn, which significantly reduces the chance of a name collision.
- What is your evaluation of the documentation?
Good.
- What is your evaluation of the potential usefulness of the library?
Very useful.
- Did you try to use the library? With which compiler(s)? Did you have any problems?
No.
- How much effort did you put into your evaluation? A glance? A quick reading? In-depth study?
A few hours.
- Are you knowledgeable about the problem domain?
Yes. -- Rainer Deyke (rainerd@eldwood.com)