On July 13, 2015 4:24:33 PM EDT, Antony Polukhin
2015-07-13 21:47 GMT+03:00 Rob Stewart
: <...> 4. A generic term I use for DLLs, shared objects, etc. is "dynamic library." I suggest that the documentation define that term once, up front, and then use it everywhere else rather than repeating the "DLL, shared object (DSO), etc." phrase. I'd also encourage using that name for the library itself (Boost.DynamicLibrary) and for the shared_object class.
I was trying to keep namings platform neutral: "dynamic library" is too Windows specific, "shared object" is too POSIX specific...
The Windows term is Dynamic Link Library, not Dynamic Library. The POSIX term is Dynamic Shared Object. They are both libraries that can be loaded dynamically rather than statically, so, Dynamic Library is the more generic name. The Apple terms are, I find, Dynamic Library or Bundle, though I don't know the specific differences between them and whether you support both or even should. Obviously, Dynamic Library isn't so generic when you add Apple to the mix.
Let it bee DLL for library abbreviation and "shared object" mostly in docs and source codes. However it does not seem so right and platform neutral right now,
Exactly. "DLL" is very much Windows specific. "shared_object" is POSIX specific. Combining them is actually confusing. For example, seeing "shared_object" in your "DLL" library implies a cross-platform adapter to DSOs for Windows rather than a generic dynamic library class.
especially when dll::shared_object and dll::library_info are nearby in code. It may be profitable to rename dll::library_info into dll::shared_object_info/dll::binary_info/???
I'd use "dl" as the namespace name "dynamic_library" as the main class name, and keep "library_info". "binary_info" could describe most anything that's binary.
I expect to be able to complete a review sometime next week, if the review manager is inclined to wait for it.
Anyway, I'm interested in your opinion, so please send the review when you'll be ready.
Any library related comments from any reviewer are welcomed even after the review end.
Of course. ___ Rob (Sent from my portable computation engine)