Thanks a lot for forwarding my email to the boost GIL list. I will check it
out.
What I meant by conversion, however was primarily converting an image to
negative and greyscale. As you may already know, the two pf them are pretty
similar and OpenMP has shown how incredibly fast the process can be using
more threads. I just feel GIL would benefit a lot from using parallel
programming.
On Sun, 8 Dec, 2019, 5:30 PM ,
Send Boost mailing list submissions to boost@lists.boost.org
To subscribe or unsubscribe via the World Wide Web, visit https://lists.boost.org/mailman/listinfo.cgi/boost or, via email, send a message with subject or body 'help' to boost-request@lists.boost.org
You can reach the person managing the list at boost-owner@lists.boost.org
When replying, please edit your Subject line so it is more specific than "Re: Contents of Boost digest..."
The boost archives may be found at: http://lists.boost.org/Archives/boost/
Today's Topics:
1. Re: [fixed_string][review] Review of fixed_string (Rob Stewart) 2. Re: Extending GIL (Mateusz Loskot)
----------------------------------------------------------------------
Message: 1 Date: Sat, 07 Dec 2019 13:23:51 -0500 From: Rob Stewart
To: boost@lists.boost.org,Phil Endecott via Boost Cc: Phil Endecott Subject: Re: [boost] [fixed_string][review] Review of fixed_string Message-ID: <142EED34-B802-4381-9FF9-C9FE999BA0F9@ptd.net> Content-Type: text/plain; charset=utf-8 On December 5, 2019 9:35:35 AM EST, Phil Endecott via Boost < boost@lists.boost.org> wrote:
Peter Dimov wrote:
- a function that checks whether the remaining capacity is at least n should be added. I suggest the name
bool can_fit( std::size_t n ) const noexcept;
although my previous choice of "has_capacity_for" has merit too.
I suggest the simpler "fits".
Make this a free function template and you can use it with other containers:
template <typename CONTAINER> bool can_fit( const CONTAINER& C, typename CONTAINER::size_type n ) noexcept { return C.capacity() - C.size() >= n; }
That's a nice idea, especially with the name "fits". :) However, if you reverse the parameters, "fits_in" would be a better name as it indicates the argument order. -- Rob
(Sent from my portable computation device.)
------------------------------
Message: 2 Date: Sun, 8 Dec 2019 01:25:04 +0100 From: Mateusz Loskot
To: boost@lists.boost.org Subject: Re: [boost] Extending GIL Message-ID: < CABUeae_cupOMOhCNvvHaeruX2ksycHhVKkHJbtCSCLr-kW-XkA@mail.gmail.com> Content-Type: text/plain; charset="UTF-8" On Sat, 7 Dec 2019 at 01:12, Siddhartha Sen via Boost
wrote: Having looked up this repository :
https://github.com/boost-gil/gil_threaded,
I feel the idea was the same, but a lot of improvement can be made.
Good, sounds like you may have a plan in mind
Also, there was no provision for image conversion, which I feel
Please, you need to be more specific here. What kind of conversion do you mean: color, channel/pixel type, format,...?
p.s. I forwarded your post to the GIL mailing list https://lists.boost.org/boost-gil/2019/12/0362.php
Best regards, -- Mateusz Loskot, http://mateusz.loskot.net
------------------------------
Subject: Digest Footer
_______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
------------------------------
End of Boost Digest, Vol 6271, Issue 1 **************************************