On 11/30/23 12:34, Дмитрий Архипов via Boost wrote:
One thing I've noticed is that several people do not think that scope guards and unique_resource belong in the same library. I at first found it curious, but then I've realised that the source of the issue is that people associate the name "Scope" with scope guards specifically.
It's not unreasonable. I also feel that it is unfortunate that the TS defined unique_resource and scope guards in the same <scope> header. I think, unique_resource should have been defined in a header of its own. But then I also think that most standard library headers are excessively coarse grained. Boost.Scope mitigates this to a degree by defining every component in its own header, so at least users don't include what they don't need. Anyway, the reason why I'm bringing scope guards together with unique_resource in one library is because it is specified so in the TS. If the review result shows that the library should be split in two, I will be fine with that.
Maybe there's an argument for a different name?
If the problem is that scope guards and unique_resource are too unrelated, I don't think renaming the library solves it. And I wouldn't like naming the library somehow generic, like Boost.RAII, as was suggested by someone. I like the Boost.Scope name, at least with respect to scope guards part. If the library as currently proposed is deemed unacceptable because scope guards and unique_resource are too unrelated, and the choice is either rename or split in two, I would rather split and keep the Boost.Scope name for the part with scope guards.