Sorry by the mistake, I was using an old version , I download the code in December, and the files inside are from October. I just revised the new version, and the documentation is much better than the older. ( The index.html don't run well because don't exist the folder doc/html/) . As see in the sort.pdf, the spreadsort function is in the boost::sort namespace. This can be coherent with my previous message. My initial idea is to put the functions in the boost::sort namespace with the names - introsort - parallel_introsort - smart_merge_sort - parallel_stable_sort - sample_sort I include the sample sort because in the parallel sorting of strings the sample sort is a 27% faster than parallel_stable_sort , and use only a 4% more of memory. The code can be in a folder with any name, by example, boost/sort/generalsort/algorithms.hpp. What's your opinion? According to your recommendations, I create the benchmarks, and the data are extracted from a file generate with a random number generator. I am trying to check in machines with many cores, I am talking with friends of universities of Madrid. I include the spreadsort in the benchmarks, and the results are impressive. I changed the name of the objects ( now is int_array) , and use the default copy constructor and the default operator =, the comparison is with the sum of all the values in the array, and all the positions of the array are filled with the random numbers of the file I am writing the documentation and changing the test programs to adapt to the boost format. In a few days, I will create a git repository, with all the information Sorry again by my mistake. Yours Francisco