28 May
2015
28 May
'15
3:59 p.m.
It looks to me that following the ?: specification would actually be easier to follow and more correct.
I sketched an implementation along those lines, which as a side effect
defines the following useful traits:
identity<T> (::type == T)
remove_cv_ref<T> (remove_cv