On 4/19/2013 8:59 PM, Preston Hamlin wrote:
I have completed a draft proposal and would appreciate some feedback:
https://www.dropbox.com/s/7xhha0a3ahk5p6r/preston_hamlin_gsoc_proposal_draft...
Seems like a fine proposal. Do take note of boost coding guidelines. -- Use the naming conventions of the C++ Standard Library (See Naming conventions rationale): * Names (except as noted below) should be all lowercase, with words separated by underscores. * Acronyms should be treated as ordinary names (e.g. xml_parser instead of XML_parser). * Template parameter names begin with an uppercase letter. * Macro (gasp!) names all uppercase and begin with BOOST_. -- http://www.boost.org/development/requirements.html#Guidelines Prefer object interfaces to pointers. For example instead of: bxPhysics* physics(___); prefer: boost::physics::physics physics_(____); Although on second thought naming might need some more thought here. What exactly is it that PxCreatePhysics creates? Is it a physics context like an OpenGL context? Is it more like a physics service like a boost::asio::io_service? Is it a physics simulation? Is it physics object factory? I'm not sure but I think it's almost certainly not just a physics. In any event it looks good to me.