On Oct 2, 2016, at 8:22 PM, Peter Dimov
wrote: Paul Fultz II wrote:
Instead a top-level cmake can bring the packages together, something like:
set(BOOST_ALL TRUE) # Whatever cmake modulues boost provide include(cmake/BoostModules.cmake)
Something like that, although BOOST_ALL does not strike me as quite correct a name, I'd call that BOOST_IS_LOCAL. (It doesn't have to be all of Boost, could be a subset.)
Yes, of course, thats probably a better name. I really couldn’t think of a good name, so I just put that.
We'll probably also need
set(BOOST_ROOT ${CMAKE_SOURCE_DIR})
This shouldn’t be needed. `CMAKE_SOURCE_DIR` is always the directory of the top root. `PROJECT_SOURCE_DIR` will give the directory of the current project. There can be multiple projects in cmake, and, ideally, there would be a project for each library or submodule. Paul