12 Oct
2021
12 Oct
'21
11:36 p.m.
On Tue, Oct 12, 2021 at 4:26 PM Peter Dimov via Boost
template<class T> void hash_combine( size_t& seed, T const& v )
In principle it sounds like an improvement, but what about the paper "Types Don't Know #?" (http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2014/n3980.html) The paper shows empirical evidence that hash_combine has poor collision properties when composing hash functions.
I also think that Boost.ContainerHash should just be renamed to Boost.Hash as that's what it is - it defines boost::hash.
So, I am thinking of taking over ContainerHash and doing all that, if there are no objections.
What happens with hash_append from the paper? Thanks