Re: [boost] [Boost-users] [typeindex v3.0] Peer review begins Mon 21st ends Wed 30th
On 23 Apr 2014 at 14:33, Paul A. Bristow wrote:
2. What is your evaluation of the implementation? OK.
Though I'm not enthusiastic about the name of namespace boost::typeind:: but I don't have any much better ideas. Perhaps someone else has?
To clarify the issue to everyone else, TypeIndex is in a rather unusual bind with regard to what namespace to use. Ideally I think we'd all agree that boost::type_index would be best, but then one of the issues raised last peer review was that there shouldn't be a boost::type_index type as could conflict with std::type_index, and if we hold that to be wise, then surely the same rationale applies for a boost::type_index namespace as well. So we end up with boost::typeind, which I don't think makes anyone happy, but it is safe.
IMO, the frequency of use of the namespace bti is probably so low that spelling it out is clearer, for example:
boost::typeind::type_id<T>().pretty_name() // human readable
Noted.
8. Do you think the library should be accepted as a Boost library?
Yes.
Thanks Paul for the vote and quick turnaround. I was worried that the review announcement had got lost. Niall -- Currently unemployed and looking for work in Ireland. Work Portfolio: http://careers.stackoverflow.com/nialldouglas/
[Not a review, but a response to one of Paul's comments]
On 23 Apr 2014 at 14:33, Paul A. Bristow wrote:
Though I'm not enthusiastic about the name of namespace boost::typeind:: but I don't have any much better ideas. Perhaps someone else has?
To clarify the issue to everyone else, TypeIndex is in a rather unusual bind with regard to what namespace to use. Ideally I think we'd all agree that boost::type_index would be best, but then one of the issues raised last peer review was that there shouldn't be a boost::type_index type as could conflict with std::type_index, and if we hold that to be wise, then surely the same rationale applies for a boost::type_index namespace as well.
So we end up with boost::typeind, which I don't think makes anyone happy, but it is safe.
I don't suppose boost::typeindex would be an improvement? That name at least immediately suggests to the reader which library to look up. Whichever name is selected, both the documentation and code comments at the namespace definition should explain, as above, why the author intentionally avoided type_index.
-----Original Message----- From: Boost [mailto:boost-bounces@lists.boost.org] On Behalf Of Nat Goodspeed Sent: 23 April 2014 16:16 To: boost@lists.boost.org Subject: Re: [boost] [Boost-users] [typeindex v3.0] Peer review begins Mon 21st ends Wed 30th
[Not a review, but a response to one of Paul's comments]
On 23 Apr 2014 at 14:33, Paul A. Bristow wrote:
Though I'm not enthusiastic about the name of namespace boost::typeind:: but I don't have any much better ideas. Perhaps someone else has?
To clarify the issue to everyone else, TypeIndex is in a rather unusual bind with regard to what namespace to use. Ideally I think we'd all agree that boost::type_index would be best, but then one of the issues raised last peer review was that there shouldn't be a boost::type_index type as could conflict with std::type_index, and if we hold that to be wise, then surely the same rationale applies for a boost::type_index namespace as well.
So we end up with boost::typeind, which I don't think makes anyone happy, but it is safe.
I don't suppose boost::typeindex would be an improvement? That name at least immediately suggests to the reader which library to look up.
I like this better too.
Whichever name is selected, both the documentation and code comments at the namespace definition should explain, as above, why the author intentionally avoided type_index.
Agreed. Yours BikeSheddingly ;-) Paul --- Paul A. Bristow Prizet Farmhouse Kendal UK LA8 8AB +44 01539 561830
On 04/23/2014 08:15 AM, Nat Goodspeed wrote:
[Not a review, but a response to one of Paul's comments]
On 23 Apr 2014 at 14:33, Paul A. Bristow wrote:
Though I'm not enthusiastic about the name of namespace boost::typeind:: but I don't have any much better ideas. Perhaps someone else has?
To clarify the issue to everyone else, TypeIndex is in a rather unusual bind with regard to what namespace to use. Ideally I think we'd all agree that boost::type_index would be best, but then one of the issues raised last peer review was that there shouldn't be a boost::type_index type as could conflict with std::type_index, and if we hold that to be wise, then surely the same rationale applies for a boost::type_index namespace as well.
So we end up with boost::typeind, which I don't think makes anyone happy, but it is safe.
I don't suppose boost::typeindex would be an improvement? That name at least immediately suggests to the reader which library to look up.
I think it is a great improvement. michael -- Michael Caisse ciere consulting ciere.com
On Wed, Apr 23, 2014 at 5:15 PM, Nat Goodspeed
I don't suppose boost::typeindex would be an improvement? That name at least immediately suggests to the reader which library to look up.
In my opinion, even boost::typeidx would be an improvement over boost::typeind.
On 24/04/2014 04:56, quoth Klaim - Joël Lamotte:
On Wed, Apr 23, 2014 at 5:15 PM, Nat Goodspeed
wrote: I don't suppose boost::typeindex would be an improvement? That name at least immediately suggests to the reader which library to look up.
In my opinion, even boost::typeidx would be an improvement over boost::typeind.
+1 to boost::typeindex. (And +0.5 to boost::typeidx.) boost::typeind makes me think "type indirection" or "type indeterminate". Which I suppose isn't an entirely bad association under the circumstances, but is probably not what was intended.
On 24 Apr 2014 at 10:54, Gavin Lambert wrote:
I don't suppose boost::typeindex would be an improvement? That name at least immediately suggests to the reader which library to look up.
In my opinion, even boost::typeidx would be an improvement over boost::typeind.
+1 to boost::typeindex. (And +0.5 to boost::typeidx.)
So, cumulatively +5 to boost::typeindex then :) Anyone interested in doing the rest of the review of TypeIndex 3.0? Is it now ready to enter Boost? Niall -- Currently unemployed and looking for work in Ireland. Work Portfolio: http://careers.stackoverflow.com/nialldouglas/
On Wednesday 23 April 2014 11:15:35 Nat Goodspeed wrote:
[Not a review, but a response to one of Paul's comments]
On 23 Apr 2014 at 14:33, Paul A. Bristow wrote:
Though I'm not enthusiastic about the name of namespace boost::typeind:: but I don't have any much better ideas. Perhaps someone else has?
To clarify the issue to everyone else, TypeIndex is in a rather unusual bind with regard to what namespace to use. Ideally I think we'd all agree that boost::type_index would be best, but then one of the issues raised last peer review was that there shouldn't be a boost::type_index type as could conflict with std::type_index, and if we hold that to be wise, then surely the same rationale applies for a boost::type_index namespace as well.
So we end up with boost::typeind, which I don't think makes anyone happy, but it is safe.
I don't suppose boost::typeindex would be an improvement? That name at least immediately suggests to the reader which library to look up.
Yes, I think that one is ok, too.
participants (7)
-
Andrey Semashev
-
Gavin Lambert
-
Klaim - Joël Lamotte
-
Michael Caisse
-
Nat Goodspeed
-
Niall Douglas
-
Paul A. Bristow