[config] C++17 macros wanted
I have been adding C++17 features to date_time. There are two config macros, I would like to have: Test for C++17’s constexpr inline feature. Maybe call it something like: BOOST_NO_CXX17_CONSTEXPR_INLINE Test for C++17’s structured binding feature. Maybe call it something like: BOOST_NO_CXX17_STRUCT_BIND
On Friday, May 26, 2017, Tal Lancaster wrote:
I have been adding C++17 features to date_time. There are two config macros, I would like to have:
Test for C++17’s constexpr inline feature. Maybe call it something like: BOOST_NO_CXX17_CONSTEXPR_INLINE Test for C++17’s structured binding feature. Maybe call it something like: BOOST_NO_CXX17_STRUCT_BIND
How soon do you need these available? (BOOST_NO_CXX17_STRUCTURED_BINDINGS and BOOST_NO_CXX17_INLINE_VARABLES seem better to me). Glen
On May 26, 2017, at 2:32 PM, Glen Fernandes via Boost
wrote: On Friday, May 26, 2017, Tal Lancaster wrote:
I have been adding C++17 features to date_time. There are two config macros, I would like to have:
Test for C++17’s constexpr inline feature. Maybe call it something like: BOOST_NO_CXX17_CONSTEXPR_INLINE Test for C++17’s structured binding feature. Maybe call it something like: BOOST_NO_CXX17_STRUCT_BIND
How soon do you need these available?
(BOOST_NO_CXX17_STRUCTURED_BINDINGS and BOOST_NO_CXX17_INLINE_VARABLES seem better to me).
I was picking names that described the officialI usage. I am fine with the name alternate if others feel that it is clearer. I’m not particularly tied to the name. As to the timing. I have started using them in my code changes but I am planning on holding off on any pull requests until something more official is in place. Tal
On Friday, May 26, 2017, Tal Lancaster wrote:
On May 26, 2017, at 2:32 PM, Glen Fernandes via Boost wrote:
On Friday, May 26, 2017, Tal Lancaster wrote:
I have been adding C++17 features to date_time. There are two config macros, I would like to have:
Test for C++17’s constexpr inline feature. Maybe call it something like: BOOST_NO_CXX17_CONSTEXPR_INLINE Test for C++17’s structured binding feature. Maybe call it something like: BOOST_NO_CXX17_STRUCT_BIND
How soon do you need these available?
(BOOST_NO_CXX17_STRUCTURED_BINDINGS and BOOST_NO_CXX17_INLINE_VARABLES seem better to me).
I was picking names that described the officialI usage. I am fine with the name alternate if others feel that it is clearer. I’m not particularly tied to the name.
As to the timing. I have started using them in my code changes but I am planning on holding off on any pull requests until something more official is in place.
These are now available in Boost.Config: 1. BOOST_NO_CXX17_STRUCTURED_BINDINGS 2. BOOST_NO_CXX17_INLINE_VARABLES Glen
Yes, it's BOOST_NO_CXX17_INLINE_VARIABLES. :-) (Misspelled it in the e-mail; the code has the right name) Glen On Wednesday, May 31, 2017, Andrey Semashev via Boostwrote: > On 05/31/17 15:26, Glen Fernandes via Boost wrote: > >> >>> These are now available in Boost.Config: >> 1. BOOST_NO_CXX17_STRUCTURED_BINDINGS >> 2. BOOST_NO_CXX17_INLINE_VARABLES >> > > That should be VARIABLES (note the I). > > _______________________________________________ > Unsubscribe & other changes: http://lists.boost.org/mailman > /listinfo.cgi/boost >
On May 31, 2017, at 7:26 AM, Glen Fernandes
wrote: On Friday, May 26, 2017, Tal Lancaster wrote:
On May 26, 2017, at 2:32 PM, Glen Fernandes via Boost wrote:
On Friday, May 26, 2017, Tal Lancaster wrote:
I have been adding C++17 features to date_time. There are two config macros, I would like to have:
Test for C++17’s constexpr inline feature. Maybe call it something like: BOOST_NO_CXX17_CONSTEXPR_INLINE Test for C++17’s structured binding feature. Maybe call it something like: BOOST_NO_CXX17_STRUCT_BIND
How soon do you need these available?
(BOOST_NO_CXX17_STRUCTURED_BINDINGS and BOOST_NO_CXX17_INLINE_VARABLES seem better to me).
I was picking names that described the officialI usage. I am fine with the name alternate if others feel that it is clearer. I’m not particularly tied to the name.
As to the timing. I have started using them in my code changes but I am planning on holding off on any pull requests until something more official is in place.
These are now available in Boost.Config: 1. BOOST_NO_CXX17_STRUCTURED_BINDINGS 2. BOOST_NO_CXX17_INLINE_VARABLES
Glen
Thanks!
participants (3)
-
Andrey Semashev
-
Glen Fernandes
-
Tal Lancaster